This is an overview of how to use VideoPad to create a video project from your videos.

As well as this help page, there is also a video tutorial available.

Adding and Removing Clips

Start your project by adding files to the media list area. Each file you add to VideoPad is considered to be a "clip". To add video files to VideoPad, either click the "Add Media" button on the toolbar, or select "File -> Capture Video" from the menu. Browse to your video files, select the files you wish to use and click "Open".

Once your files have been added, if you wish to remove any of them, right click on the files and select "Remove items" from the menu.

Using the Clip Preview Area

When you select a clip in the media list area, the clip will become available to edit in the "clip preview area". Here you can control the playback of the clip by clicking the Play/back/forward buttons. You can also jump to a position in the clip by dragging your cursor along the timeline whilst holding down the left mouse button.

Adjusting the In / Out Points of a Clip

If you need a particular section of your video clip, you can use the red and blue flags to set "In" and "Out" points (or press "Ctrl+," and "Ctrl+." hot keys). These flags define the beginning and end of the clip once it is added to the sequence.

You can also "cut" new clips out of an existing clip by clicking the "Save as new clip" button to the right of the In / Out flags (icon of video file with star in top right corner). When clicked, you will see a new clip has been created and added to the media list area.

VideoPad can also be set to show previous and next frames of the video file. This can assist in the editing process, however is considered to be an Advanced feature. To switch to this view, right click over the actual preview of the clip and select "Show previous and next frames".

Placing clips on the Sequence

Once you are happy with the In/Out settings of your clip you can then place it on the Project Sequence. You can do this two ways.

The first is from the media list area. Just select your clip in the list and with the left mouse button pushed, drag it down onto the Sequence area. Alternatively, you can right click on the selected clip and choose "Add Items to Sequence" from the menu. Your clip has now been added to the Sequence and is part of your project.

The second way to add clips to the Sequence is from the clip preview area. On the clip preview area's toolbar, click the "Add clip to sequence" button (green, downward pointing arrow) to the right of the "Save as new clip" button. Your clip has now been added to the end of your Sequence and is part of your project.

Editing clips on the Sequence

You can adjust a clip length by resizing the clip's frame on the Sequence. To do this, first select the clip on the sequence you want to edit so it becomes highlighted (dark blue). You can then click and drag from the beginning or end of the clip's frame to adjust the In and Out points of the clip. This will give you the same result as adjusting the In/Out Flags in the Clip Preview area.

You can also add effects to your clips on the Sequence. To add effects, click the green star icon in the bottom left corner of a clip on the Sequence. Alternatively, you can select a clip and then click "Edit -> Clip -> Adjust Effects" in the top menu. To apply effects to multiple clips at once, select the first clip, press the Shift key and left-click on the last clip you want to select. To learn more please see Effects.

To add a transition between clips, click the blue rectangle icon in the bottom right corner of a clip on the Sequence. Alternatively, you can select a clip and then choose the transition you would like to apply from the drop down to the left of the Sequence area, or click "Edit -> Clip -> Add Transition" in the top menu. You can also multi-select clips and apply a single transition to many clips. To learn more please see Transitions.

To split a clip at a particular point, navigate using the timeline (on top of the Sequence) and drag the slider to the point where you would like to split the clip. You can use the Sequence Preview area to reference where you are in the clip. Once you are happy your at the point where you would like to split the clip, click the "Split Clip" button on the Video Track panel.

Working with Audio

If a clip has native audio it will be displayed in the "Clip Audio Track" area when a clip is added to the Sequence.

Alternatively, you can choose to add sound effects from the NCH Sound Library by right-clicking any empty space on the soundtrack and selecting "Add Sound Effect From NCH Sound Effect Library..." from the context menu. The file you choose will be added at the location you have right-clicked.

You can also add independent audio to the Sequence. After adding the audio file to the media list area ("Add Media" button from the toolbar), just drag and drop it to the "Soundtrack" area of the Sequence. Once on the Sequence, you can move the soundtrack around and adjust the In and Out points just like a normal video clip.

You can also move your sound files from one track to another using drag-and-drop option or by selecting "Move to track" from the right-click context menu.

Building the Project

Once you have completed your project you need to build it. Click the "Save Movie" button on the toolbar. A new dialog box will appear. Select the destination device and format you want your project to be built for. There is a help page for every destination type (access them by clicking the "Help" button in the bottom of the "Video Output Setup" dialog).

Saving and loading your video project

If you want to save your project select "File -> Save Project As" from the menu and select a destination file to save your project to.

To load the saved project select "File -> Open Project..." from the menu. Then select your saved project file.

Warning: when you save your project file you do not actually save your movies into it. Only filenames are saved. If you want all the data including clips, narrations and soundtracks to be safe do not rename, delete or move any files that are used in the project from their original folder.