SHRM Learning System® for SHRM-CP® and SHRM-SCP® Certification Preparation Course

Earn the new standard in HR certification and establish yourself as a globally recognized human resource expert.

The SHRM Learning System for SHRM-CP and SHRM-SCP Certification Preparation Course is designed for candidates preparing for the professional HR certification exams administered by the SHRM Certification Commission.

Course topics include HR competencies, people, organization and workplace. HR professionals and business leaders who are not exam candidates but want an in-depth understanding of human resources may also enroll in this program.

Eligibility Criteria

This course is designed primarily for exempt and nonexempt level HR professionals seeking SHRM-CP® or SHRM-SCP® certification. Candidates for certification must meet the eligibility criteria established by the SHRM Certification Commission.

Less Than a Bachelor's Degree

Credential HR-related Degree Non-HR Degree
SHRM-CP 3 years in HR role 4 years in HR role
SHRM-SCP 6 years in HR role 7 years in HR role

Bachelor's Degree

Credential HR-related Degree Non-HR Degree
SHRM-CP 1 year in HR role 2 years in HR role
SHRM-SCP 4 years in HR role 5 years in HR role

Graduate Degree

Credential HR-related Degree Non-HR Degree
SHRM-CP Currently in HR role 1 year in HR role
SHRM-SCP 3 years in HR role 4 years in HR role

Course Overview

Price Discounts Modality Materials
$1,300 early bird if you register 30 days before the course
$1,450 standard price
SHRM members, NIU alumni, and NIU staff and students receive a discount Instructor-led online or in person Course materials and online resources included

Register

Testimonial

I never worked so hard to pass a test but couldn't be happier. I went to every class, put in the work, and studied so hard because I feel so proud and would recommend taking the course and sitting through the exam to every HR professional out there!

Jaclyn O’Brien Mills

Contact Us

NIU Continuing and Professional Education
NIUCPE@niu.edu

Sign Up for Updates

* indicates required
Back to top