Skip navigation

Issue with Java 7 Update 51 Causes Problem Running Apps

Posted: 2/13/14

ITS has identified a problem with the latest version of Java 7, version 51, released 1/14/14. This Java security update does not allow unsigned Java applets to run. Users have encountered this problem in Blackboard, and WebCRMA, where the Java applets will not run but instead display an Application Error Security Exception "Missing required Permissions manifest attribute in main jar:"

One solution is to add trusted websites to Java 7 in the Exception Site List now included in version 51. To do this, open the Java control panel then on the security tab, go to "Edit site list" and click "Add" to add the following 3 sites, all trusted at NIU: https://bbcollab.niunt.niu.edu:8443 https://webcourses.niu.edu http://niu.edu

This will allow the Java applets to run. Users who do not have sufficient rights to edit their computer's Java settings should be referred to their LAN Admins for assistance.


Need Technical Assistance?

Call the IT Service Desk at 815.753.8100 or email ServiceDesk@niu.edu


Need Assistance Teaching with Blackboard?

Call the Faculty Development and Instructional Design Center at 815.753.0595 or email facdev@niu.edu


Keeping Current

Stay up-to-date with the latest news regarding teaching with Blackboard at NIU, by following @NIUBlackboard on Twitter